#74 ✓invalid
Steve Karpik

prepend-xx and colborder bug in IE?

Reported by Steve Karpik | April 19th, 2009 @ 10:20 PM

I've created a sample html page using prepend-1 and colborder. It renders perfectly in FF and Chrome. Doesn't look so good in IE 7 (Vista).

Prepend-xx seems not to work properly. Likewise for colborder. I've attached screenshots for all three browsers and the source code.

I'm using Version 0.8 - Date November 11, 2008.

Comments and changes to this ticket

  • Steve Karpik

    Steve Karpik April 19th, 2009 @ 10:31 PM

    Here are the screen shots and the html (the first file I uploaded had some typos in the text).

  • garethjmsaunders

    garethjmsaunders June 17th, 2009 @ 05:47 PM

    • Tag set to quirks mode, doctype, ie7

    Hi Steve, try adding a doctype to your HTML file. I just added the XHTML 1.0 Transitional doctype and your code rendered fine in IE7 (XP), without the doctype and it renders just as your screenshots.

    Any doctype (I checked both HTML 4.01 and XHTML, strict and transitional) with the correct URL seems to work, such as this:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
     "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    

    Hope that helps.

    Gareth

  • Christian Montoya

    Christian Montoya August 20th, 2009 @ 03:18 PM

    • State changed from “new” to “invalid”

Please Sign in or create a free account to add a new ticket.

With your very own profile, you can contribute to projects, track your activity, watch tickets, receive and update tickets through your email and much more.

New-ticket Create new ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile ยป

The Blueprint CSS framework

Attachments

Pages